Des millions de sites WordPress et Drupal vulnérables aux attaques DoS - Arobasenet.com


Des millions de sites WordPress et Drupal vulnérables aux attaques DoS

faille de sécurité WordPress et Drupal


Les sites web développés à partir de WordPress ou Drupal nécessitent de toute urgence une mise à jour pour cause de vulnérabilité.

En effet, une faille de sécurité critique vient d'être découverte dans la manière dont Drupal et WordPress implémente le protocole XML-RPC, permettant à tout pirate de mettre tout site hors service via la méthode DoS (Denial of Service ou Deni de Service).

Une technique de hacking qui rend alors le site web attaqué totalement inacessible.

Une vunérabilité qui rend le site inaccessible


La toute dernière version de WordPress 3.9.2 vise justement à corriger ce problème dans le processus XML de PHP qui pourrait être exploité pour déclencher une attaque DoS. La faille de sécurité étant, elle, présente dans toutes les versions précédentes de WordPress.

Lorsque la vulnéraibilité est exploitée, c'est tout le site web ou le serveur qui devient immédiatement inaccessible aux internautes.

La vulnérabilité XML de WordPress et Drupal peut causer un épuisement complet du CPU et de la mémoire et la base de données du site atteind rapidement son nombre maximal de connexions ouvertes. Et ainsi, le site et le serveur attaqués ne sont plus disponibles pendant une certaine durée. Ce qui affecte donc la disponibilité totale de votre site Web.


Mise à jour de WordPress et Drupal


Comme mentionné plus haut, la faille de sécurité XML est présente dans les versions 3.5 à 3.9.1 de WordPress. Cette même vulnérabilité se retrouve sur Drupal dans les versions 6.x à 7.x.

Ces deux systèmes de gestion de contenu (CMS) mettent à disposition des mises à jours qui devraient résoudre le problème et recommandent fortement à tous les utilisateurs d'effectuer leur mise à jour le plus rapidement possible.

Aucun commentaire